Author Topic: Atik Base / Stellarmate  (Read 309 times)

0 Members and 1 Guest are viewing this topic.

Rick

  • Administrator
  • Galaxy Cluster
  • *
  • Posts: 6387
    • http://www.orpington-astronomy.org.uk
Re: Atik Base / Stellarmate
« Reply #15 on: May 09, 2019, 09:40:41 »
Nothing quite like power adapters with the same connectors and different voltages for blowing electronics...

A recent victim here was a 5V LED light that got itself attached to the 12V charger for my Kenwood TH72 handheld transceiver. At least it was the light that blew, not the radio's charger...

There's a common problem with switch-mode power supplies where the low voltage output floats at some level between ground and 300V or so. Given a ground to work against, they usually settle down to a sensile point, but if you plug something powered by one of those into something that's firmly grounded you sometimes see sparks. I always try to plug all the data connections in before applying power to affected items...
« Last Edit: May 09, 2019, 09:47:20 by Rick »

The Thing

  • Mr October
  • O. A. S.
  • Galaxy Class
  • *
  • Posts: 2718
  • The OAS International Branch
Re: Atik Base / Stellarmate
« Reply #16 on: May 09, 2019, 12:59:35 »
Sparks from USB connectors! Only when struck by lightning round here. I always plug data cables before powering up and have different or labelled power leads for everything. 12v items all use an old HiFi system multiplug unit. The plugs only.fit in it so no problems and I have a separate supplies for dew heater + focuser, mount + camera.